mercoledì 14 giugno 2017

The OVF package requires unsupported hardware



Quando si prova a 'deployare' un file OVA creato con hardware version superiore all'ESXi di destinazione compare questo errore.
Per poter risolvere questo problema basta inserire nel file vmx la versione hardware desiderata facendo questa procedura.

Scaricare ed installare il tool OVFTool da questo link

https://my.vmware.com/web/vmware/details?productId=352&downloadGroup=OVFTOOL350

eseguire i seguenti comandi:

ovftool <percorso del file .ovf > <percorso del file .vmx>

Ottenuto il file VMX modificate la versione hardware contenuta in esso nella versione desiderata e salvate il file.
Convertite nuovamente il file nel formato OVF con i comandi seguenti:

ovftool <percorso del file .vmx> <percorso del file .ovf>

La vostra macchina è pronta per essere 'deployata'




Nessun commento:

Posta un commento